Introduction to AutoCAD Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Line / L</td>
<td></td>
<td>Draw &gt; Line</td>
<td>Draw a straight line segment from one point to the next</td>
</tr>
</tbody>
</table>

Creates straight line segments

- **Draw toolbar:**
- **Draw menu:** Line
- **Command entry:** `line`

Specify first point. Specify a point or press ENTER to **continue** from the last drawn line or arc.
Specify next point or [Close/Undo]:

---

**Continue**

Continues a line from the endpoint of the most recently drawn line.

Before pressing ENTER | After pressing ENTER
---|---

If the most recently drawn line is an arc, its endpoint defines the starting point of the line, and the line is drawn tangent to the arc.

Before pressing ENTER | After pressing ENTER
**Close**

Ends the last line segment at the beginning of the first line segment, which forms a closed loop of line segments. You can use Close after you have drawn a series of two or more segments.

![Before entering](image1.png) ![After entering](image2.png)

**Undo**

Erases the most recent segment of a line sequence.

![Before entering](image3.png) ![After entering](image4.png)

Entering u more than once backtracks through line segments in the order you created them.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circle</td>
<td>Circle / C</td>
<td>![Circle Icon]</td>
<td>Draw &gt; Circle &gt; Center, Radius</td>
<td>Draws a circle based on a center point and radius.</td>
</tr>
</tbody>
</table>

Creates a circle

- **Draw toolbar:**
- **Draw menu:** Circle
- **Command entry:** `circle`

Specify **center point** for circle or [3P (Three Points)]/[2P (Two Points)]/[Ttr (tan tan radius)];
Specify a point or enter an option

**Center Point**

Draws a circle based on a center point and a diameter or a radius.

Specify radius of circle or [Diameter]: Specify a point, enter a value, enter `d`, or press ENTER

**Radius**

Defines the radius of the circle. Enter a value, or specify a point (2). The distance between this point and the center point determines the radius of the circle.

![Radius Diagram]

**Diameter**

Draws a circle using the center point and a specified distance for the diameter.

Specify diameter of circle <current>: Specify a point (2), enter a value, or press ENTER

![Diameter Diagram]
3P (Three Points)

Draws a circle based on three points on the circumference.

Specify first point on circle: Specify a point (1)
Specify second point on circle: Specify a point (2)
Specify third point on circle: Specify a point (3)

2P (Two Points)

Draws a circle based on two endpoints of the diameter.

Specify first endpoint of circle's diameter: Specify a point (1)
Specify second endpoint of circle's diameter: Specify a point (2)

TTR (Tangent, Tangent, Radius)
**TTR (Tangent, Tangent, Radius)**

Draws a circle with a specified radius tangent to two objects.

Specify point on object for first tangent of circle: *Select a circle, arc, or line*
Specify point on object for second tangent of circle: *Select a circle, arc, or line*
Specify radius of circle *<current>*:

Sometimes more than one circle matches the specified criteria. The program draws the circle of the specified radius whose tangent points are closest to the selected points.
**Command | Keystroke | Icon | Menu | Result**

| Erase | **Erase / E** | ![Icon] | Modify > Erase | Erases an object. |

Removes objects from a drawing

Modify toolbar:  
Modify menu: Erase

Shortcut menu: Select the objects to erase, right-click in the drawing area, and click Erase.

Command entry: `erase`

Select objects: Use an object selection method and press ENTER when you finish selecting objects

The objects are removed from the drawing.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>U</td>
<td>🔄</td>
<td>Edit &gt; Undo</td>
<td>Undoes the last command.</td>
</tr>
</tbody>
</table>

(Don't use 'Undo' for now)

Reverses the effect of commands

Standard toolbar:

Command entry: undo

Enter the number of operations to undo or [Auto/Control/BEgin/End/Mark/Back]: Enter a positive number, enter an option, or press ENTER to undo a single operation

UNDO displays the command or system variable name on the command line to indicate that you have stepped past the point where the command was used.

**Note** UNDO has no effect on some commands and system variables, including those that open, close, or save a window or a drawing, display information, change the graphics display, regenerate the drawing, or export the drawing in a different format.

**Number**

Undoes the specified number of preceding operations. The effect is the same as entering u multiple times.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trim</td>
<td>TRIM / TR</td>
<td>![icon]</td>
<td>Modify &gt; Trim</td>
<td>Trims objects to a selected cutting edge.</td>
</tr>
</tbody>
</table>

Trims objects at a cutting edge defined by other objects

- **Modify toolbar:**
  - ![icon]
- **Modify menu:** Trim
- **Command entry:** `trim`

  Current settings: Projection = current Edge = current

  Select cutting edges...

  Select objects or <select all>: *Select one or more objects and press ENTER, or press ENTER to select all displayed objects*

  ![selected cutting edge]

Select the objects that define the cutting edges to which you want to trim an object, or press ENTER to select all displayed objects as potential cutting edges. TRIM projects the cutting edges and the objects to be trimmed onto the XY plane of the current user coordinate system (UCS).

**Note** To select cutting edges that include blocks, you can use only the single selection, Crossing, Fence, and Select All options.

- Select **object to trim** or **shift-select to extend** or [Fence/Crossing/Project/Edge/eRase/Undo]: *Select an object to trim, hold down SHIFT and select an object to extend it instead, or enter an option*

Specify an object selection method to select the objects to trim. If more than one trim result is possible, the location of the first selection point determines the result.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend</td>
<td>EXTEND / EX</td>
<td></td>
<td>Modify &gt; Extend</td>
<td>Extends objects to a selected boundary edge.</td>
</tr>
</tbody>
</table>

Extends an object to meet another object

 Modi toolbar: 

 Modify menu: Extend

 Command entry: extend

Select boundary edges...

Select objects or <select all>: Select one or more objects and press ENTER, or press ENTER to select all displayed objects

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: Select objects to extend, or hold down SHIFT and select an object to trim, or enter an option

**Boundary Object Selection**

Uses the selected objects to define the boundary edges to which you want to extend an object.

**Object to Extend**

Specifies the objects to extend. Press ENTER to end the command.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>OFFSET / O</td>
<td></td>
<td>Modify &gt; Offset</td>
<td>Offsets an object (parallel) by a set distance.</td>
</tr>
</tbody>
</table>

Creates concentric circles, parallel lines, and parallel curves

Modify toolbar: 
Modify menu: Offset
Command entry: offset

Current settings: Erase source = current Layer = current OFFSETGAPTYPE = current
Specify offset distance or [Through/Erase/Layer] <current>: Specify a distance, enter an option, or press ENTER

The OFFSET command repeats for convenience. To exit the command, press ENTER.

**Offset Distance**

Creates an object at a specified distance from an existing object.

Select object to offset or [Exit/Undo] <exit>: Select one object, enter an option, or press ENTER to end the command
Specify point on side to offset or [Exit/Multiple/Undo] <exit or next object>: Specify a point (1) on the side of the object you want to offset or enter an option

Exit
Exits the OFFSET command.

Multiple
Enters the Multiple offset mode, which repeats the offset operation using the current offset distance.

Undo
Reverses the previous offset.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td>Move / M</td>
<td>![Icon]</td>
<td>Modify &gt; Move</td>
<td>Moves an object or objects</td>
</tr>
</tbody>
</table>

Moves objects a specified distance in a specified direction

Modify toolbar:
Modify menu: Move
Shortcut menu: Select the objects to move, and right-click in the drawing area. Click Move.

Command entry: move

Select objects: Use an object selection method and press ENTER when you finish
Specify base point or [Displacement]<Displacement>: Specify a base point or enter d
Specify second point or <use first point as displacement>: Specify a point or press ENTER

The two points you specify define a vector that indicates how far the selected objects are to be moved and in what direction.

If you press ENTER at the Specify Second Point prompt, the first point is interpreted as a relative X, Y, Z displacement. For example, if you specify 2,3 for the base point and press ENTER at the next prompt, the objects move 2 units in the X direction and 3 units in the Y direction from their current position.

**Displacement**

Specify displacement <last value>: Enter coordinates to represent a vector

The coordinate values that you enter specify a relative distance and direction.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copy / CP</td>
<td>🕹️</td>
<td>Modify &gt; Copy</td>
<td>Copies object(s) once or multiple times</td>
</tr>
</tbody>
</table>

Copies objects a specified distance in a specified direction

Modify toolbar: 🕹️  
Modify menu: Copy
Shortcut menu: Select the objects to copy, and right-click in the drawing area. Click Copy Selection.
Command entry: `copy`

Select objects: Use an object selection method and press ENTER when you finish
Specify base point or [Displacement]<Displacement>: Specify a base point or enter d

The two points you specify define a vector that indicates how far the copied objects are to be moved and in what direction.

If you press ENTER at the Specify Second Point prompt, the first point is interpreted as a relative X,Y,Z displacement. For example, if you specify 2,3 for the base point and press ENTER at the next prompt, the objects are copied 2 units in the X direction and 3 units in the Y direction from their current position.

The COPY command repeats for convenience. To exit the command, press ENTER.

Displacement

Specify displacement <last value>: Enter coordinates to represent a vector

The coordinate values that you enter specify a relative distance and direction.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stretch</td>
<td>Stretch / S</td>
<td></td>
<td>Modify &gt; Stretch</td>
<td>Stretches an object after you have selected a portion of it</td>
</tr>
</tbody>
</table>

Modify toolbar:
Modify menu: Stretch
Command entry: stretch

Select objects to stretch by crossing-window or crossing-polygon...
Select objects: Use the polygon option or the crossing object selection method, and press ENTER. Individually selected objects and objects that are completely enclosed by the crossing selection are moved rather than stretched.

STRETCH moves only the vertices and endpoints that lie inside the crossing selection, leaving those outside unchanged. STRETCH does not modify 3D solids, polyline width, tangent, or curve-fitting information.

**Base Point**
Specify base point or [Displacement] <last displacement>: Specify a base point or enter displacement coordinates
Specify second point or <use first point as displacement>: Specify a second point, or press ENTER to use the previous coordinates as a displacement

**Displacement**
Specify displacement <last value>: Enter displacement values for X,Y (and optionally Z)

If you enter a second point, the objects are stretched the vector distance from the base point to the second point. If you press ENTER at the Specify Second Point of Displacement prompt, the first point is treated as an X,Y,Z displacement.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mirror</td>
<td><strong>Mirror / MI</strong></td>
<td>![Mirror Icon]</td>
<td><strong>Modify &gt; Mirror</strong></td>
<td>Creates a mirror image of an object or selection set</td>
</tr>
</tbody>
</table>

Creates a mirror image copy of objects

Modify toolbar: 
Modify menu: Mirror

**Command entry:** `mirror`

**Select objects:** *Use an object selection method and press ENTER to finish*

**Specify first point of mirror line:** *Specify a point*

**Specify second point of mirror line:** *Specify a point*

The two specified points become the endpoints of a line about which the selected objects are mirrored. For mirroring in 3D, this line defines a mirroring plane perpendicular to the XY plane of the user coordinate system (UCS) containing the mirror line.

**Erase source objects? [Yes/No] <N>: Enter y or n, or press ENTER**

**Yes**
Places the mirrored image into the drawing and erases the original objects.

**No**
Places the mirrored image into the drawing and retains the original objects.
<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate</td>
<td>Rotate / RO</td>
<td>![Rotate Icon]</td>
<td>Modify &gt; Rotate</td>
<td>Rotates objects to a certain angle</td>
</tr>
</tbody>
</table>

**Rotates objects around a base point**

- **Modify toolbar:** ![Rotate Icon]
- **Modify menu:** Rotate
- **Shortcut menu:** Select the objects to rotate, and right-click in the drawing area. Click Rotate.

**Command entry:** rotate

- Current positive angle in UCS: ANGDIR=current ANGBASE=current
- Select objects: Use an object selection method and press ENTER when you finish
- Specify base point: Specify a point
- Specify rotation angle or [Copy/Reference]: Enter an angle, specify a point, enter c, or enter r

**Rotation Angle**

Determines how far an object rotates around the base point.
The axis of rotation passes through the specified base point and is parallel to the Z axis of the current UCS.

**Copy**

Creates a copy of the selected objects for rotation.

**Reference**

Rotates objects from a specified angle to a new, absolute angle.

Specify the reference angle <last reference angle>: Specify an angle by entering a value or by specifying two points

Specify the new angle or [Points] <last new angle>: Specify the new absolute angle by entering a value or by specifying two points

When you rotate a viewport object, the borders of the viewport remain parallel to the edges of the drawing area.
### Fillet

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fillet</td>
<td><strong>Fillet / F</strong></td>
<td>![Icon]</td>
<td>Modify &gt; Fillet</td>
<td>Creates a round corner between two lines</td>
</tr>
</tbody>
</table>

Rounds and fillets the edges of objects

- **Modify toolbar:**
- **Modify menu:** Fillet
- **Command entry:** `fillet`

Current settings: Mode = current, Radius = current

Select **first object** or [**Undo/Polyline/Radius/Trim/Multiple**]: Use an object selection method or enter an option

#### First Object

Selects the first of two objects required to define a 2D fillet or selects the edge of a 3D solid to round or fillet the edge.

Select **second object** or shift-select to apply corner: Use an object selection method or hold down **SHIFT** and select an object to create a sharp corner

If you select lines, arcs, or polylines, their lengths adjust to accommodate the fillet arc. You can hold down **SHIFT** while selecting the objects to override the current fillet radius with a value of 0.

If the selected objects are straight line segments of a 2D polyline, they can be adjacent or separated by one other segment. If they are separated by another polyline segment, FILLET deletes the segment that separates them and replaces it with the fillet.

More than one fillet can exist between arcs and circles. Select the objects close to where you want the endpoints of the fillet.
FILLET does not trim circles; the fillet arc meets the circle smoothly.

If you select a 3D solid, you can select multiple edges, but you must select the edges individually.

Enter fillet radius <current>: Specify a distance or press ENTER
Select an edge or [Chain/Radius]: Select edge(s), enter c, or enter r
### Chamfer

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke</th>
<th>Icon</th>
<th>Menu</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chamfer</td>
<td>Chamfer / CHA</td>
<td><img src="image" alt="Icon" /></td>
<td>Modify &gt; Chamfer</td>
<td>Creates an angled corner between two lines</td>
</tr>
</tbody>
</table>

Bevels the edges of objects

- Modify toolbar:
- Modify menu: Chamfer
- Command entry: `chamfer`

(TRIM mode) Current chamfer Dist1 = current, Dist2 = current

Select first line or [Undo/Polyline/Distance/Angle/Trim/Method/Multiple]: Use an object selection method or enter an option

### Distance

Sets the distance of the chamfer from the endpoint of the selected edge.

Specify first chamfer distance `<current>`:

Specify second chamfer distance `<current>`:

If you set both distances to zero, CHAMFER extends or trims the two lines so they end at the same point.